Braille Music Notator

version 0.9.3b · 17 September 2019

Toby W. Rush
Associate Professor of Music Theory and Technology
University of Dayton

User Guide

Table of Contents

Philosophy and Purpose

Braille Music Notator is designed to provide an intuitive interface for creating and editing scores using braille music notation. Braille Music Notator does not translate music to or from traditional music notation, though it does allow editing of scores created in other translation utilities.

The philosophy behind Braille Music Notator is that the most efficient and elegant braille scores result when the engraver is familiar with braille music notation, and when he or she can manipulate the specific details of the braille score instead of depending wholly on an automatic translation program to do so.

Additionally, Braille Music Notator allows sighted music teachers to more effectively teach students who have visual impairments by helping the teacher gain fluency in braille music notation.

Fortunately, the basic tenets of braille music notation are not difficult to learn; the most daunting task is the memorization of the braille symbols. Braille Music Notator removes this difficulty by displaying the symbols as familiar musical symbols on screen.

Software Requirements

Braille Music Notator has been tested successfully on the most current versions of Safari, Chrome, Firefox, and Opera, on both MacOS and Windows. The utility is also available on mobile devices such as iPads with some limitations in functionality.

Braille Music Notator is compatible with screen-reading software according to WAI-ARIA standards, and has been tested with VoiceOver on MacOS and JAWS on Windows. (Windows' built-in screen reader, Narrator, is not supported at this time.)

Braille Music Notator supports note entry with a MIDI keyboard, but requires a compatible web browser. For more information, see MIDI Compatible Browsers.

Starting the Utility

To begin using Braille Music Notator, open the program in your web browser. Braille Music Notator is a web application, meaning it operates from within your web browser; no software download is necessary. (To use Braille Music Notator without an internet connection, see Using Braille Music Notator Offline.)

The Braille Music Notator window is divided into two large sections: the notation area and the control area.

The Notation Area

For a visual introduction to using Braille Music Notator, visit the Video Tutorials page.

The notation area is the top part of the window, and it displays the currently open score. The notation area consists of a grid; each cell of this grid can hold a single braille character, or can be empty. Every tenth row and column is numbered along the left and top of the window, respectively. When Braille Music Notator is opened for the first time, the score is blank.

One of the cells is shaded slightly; this cell is the cursor. It indicates where the next character will be placed. When a character is added to the score (by clicking or typing), the cursor advances to the left, ready to place the next character.

Moving the Cursor

The cursor can be moved using the arrow keys on the keyboard or by clicking on a new cell with the mouse.

Scrolling the Notation Area

When the cursor is moved beyond the boundaries of the notation area with the arrow keys, the notation area scrolls to keep the cursor in view. The score is infinitely large in height and width. The notation area can also be scrolled using the scrollwheel functions of your mouse or trackpad; see your computer's user manual for more information about these functions.

Selecting Multiple Cells

Multiple contiguous cells can be selected at once in the score window. To select multiple cells with the mouse, click and drag over the cells in the notation window. Alternately, click once to place the cursor at one corner of the area you wish to select, then hold the Shift key and click the cursor at the opposite corner of the area you wish to select. This method allows the selection of areas which are larger than what is currently displayed in the notation area.

To select multiple cells with the arrow keys, hold the Shift key down while using the arrow keys. To return to a single cell selection, click on a single cell with the mouse or type an arrow key without holding the Shift key.

The Control-A shortcut will automatically select all characters in the score. (See Keyboard Shortcuts.)

Page Breaks

When Show Page Breaks is enabled (see Options), cells to the right of the currently set page width are shaded, and a horizontal page divider is shown separating each page. Page numbers are displayed in the right margin at the top of each page. Characters can be entered in the margin area, but will not be included in exported files or appear on embossed pages.

Magnification

Cell size in the notation area grid can be made smaller, allowing more cells to be viewed at once, or larger, increasing the size and visibility of each cell. To adjust the magnification, adjust the Score Size value in the Options Tab (see Options), or the keyboard shortcuts: Control-Equals increases magnification and Control-Hyphen decreases magnification (see Keyboard Shortcuts).

The Control Area

For a visual introduction to using Braille Music Notator, visit the Video Tutorials page.

The control area appears at the bottom of the window, and includes a keyboard diagram showing braille music symbols assigned to each key. Symbols can be entered into the score by clicking on the keyboard diagram or by typing the corresponding key on the computer keyboard.

Keys are identified with the braille musical symbol they generate. The actual name of the key is displayed in a faded color in the lower left-hand corner of the key. Colors are used to identify types of symbols. Gray key icons indicate unused keys, which do not affect the score.

Other Keyboards

More keyboards, each containing more symbols, are available by clicking the buttons on the left side of the control area. The numbered keyboards contain musical symbols, each of which correspond to one or more braille characters. The final keyboard, marked "Aa," contains letters and numbers for typing literary braille.

Pressing the tab key rotates through the available keyboards. Holding shift while pressing the tab key rotates through the keyboards in reverse.

Contextual Help

Moving the mouse over any key displays the type of symbol represented, a short description, and in many cases an example of that symbol's use.

Resizing the Control Area

The control area can be resized by clicking and dragging the top edge of the control area. Resizing the control area also resizes the notation area, but does not alter the score in any way.

Entering and Editing the Score

For a visual introduction to using Braille Music Notator, visit the Video Tutorials page.

To begin creating a score, simply open Braille Music Notator, place the cursor where you wish to begin, and click in the control area or type to enter musical symbols. To relocate the cursor, you can click on the new position with the mouse, or you can use the following keys:

Removing Characters

Characters can be removed from the score using the following methods:

Inserting Characters

If the cursor is placed on an existing character, any new character placed into the score will overwrite the existing character. To insert a character into the score, hold the Shift key while typing the character or clicking on the keyboard chart. All characters in that row to the right of the cursor will be moved to the right, allowing the new character to be inserted.

To insert a blank row into the score, use the keyboard shortcut Control-Down Arrow. The current rows and all rows below it will be moved down one row.

Undo and Redo

To undo the most recent change to the score, use the keyboard shortcut Control-Z (Undo). Repeating this command will continue backward through earlier edits to the score.

After using Undo, changes can be reapplied to the score with the keyboard shortcut Control-Y (Redo). Repeating this command will continue forward through subsequent edits to the score.

Cut, Copy and Paste

Braille Music Notator supports the same behaviors for copying and pasting data found in most word processors, as described below:

Clipboard data is stored in a format specific to Braille Music Notator; characters copied to the clipboard from the score and pasted into other programs will appear to be random, but can be pasted back into Braille Music Notator. To export characters in a format that can be used in other braille programs, see Export File. Characters copied from other sources and pasted into the Braille Music Notator window will be added the score as follows:

If the clipboard contains Unicode braille characters, the characters will be automatically translated into Braille ASCII and pasted as indicated above (see Unicode Braille Characters).

How Characters are Displayed

When Braille Music Notator is opened, characters are automatically shown using icons which describe the musical value of each braille character. If the score contains a braille character which does not have a musical meaning understood by Braille Music Notator, the braille character itself (comprised of one to six dots) is displayed.

To force Braille Music Notator to display all characters in their standard braille form, deselect "Show Translated Braille" (see Options). Alternately, the keyboard shortcut Control-B can be used to switch between translated and untranslated braille.

When braille characters are shown, unused dots in the braille character are indicated by a smaller dot. To hide these smaller dots, deselect "Show Small Dots" (see Options) or use the keyboard shortcut Control-D to switch between the settings.

A single braille character can have multiple musical meanings. To rotate through the possible meanings of one or more braille symbols, select the symbols and use the keyboard shortcut Control-R. Continuing to use the keyboard shortcut will eventually "wrap around" to the original meaning (see Braille Music Characters).

To force Braille Music Notator to interpret one or more selected characters as text, use the keyboard shortcut Control-T. (This is the equivalent of using Control-R to rotate each character to its first text value.) To force Braille Music Notator to interpret one or more selected characters as music, use the keyboard shortcut Shift-Control-T.

File Commands

For a visual introduction to working with files in Braille Music Notator, visit the Video Tutorials page.

Scores created in Braille Music Notator can be saved to your local hard disk so they may be opened and edited later. Files can also be exported to send to a braille embosser or other device. Commands for working with files are found by clicking the "File" button in the upper right hand corner of the Braille Music Notator window, which brings up the File Tab. The File Tab is dismissed by clicking the File Button again. File commands can also be issued without opening the File Tab by using the associated keyboard shortcuts (see Keyboard Shortcuts).

New File

The New File command discards the current score, leaving a blank notation area in which to begin a new score. The existing score is not saved; a warning appears when using this command before the old data is discarded. The New File command can be issued using the Control-N keyboard shortcut.

Open File

Open file allows you to view or edit a score which was previously saved to your computer. When Open File is selected, Braille Music Notator presents a file dialog, allowing you to select a file from your computer's hard drive. The selected file is displayed in the notation area and can be viewed and edited. The Open File command can be issued using the Control-O keyboard shortcut.

Any existing score will be discarded when a new file is opened; Braille Music Notator will display a warning before doing so, allowing you to save your previous work before opening the new file.

Files can also be opened by dragging them from the File Manager (Windows) or Finder (Mac OS) directly into the notation area.

Save File

Choosing Save File will save the current score to a file on your computer's hard disk. You will be given the option of naming the file before saving. The file type produced (.brm) is designed to work specifically with Braille Music Notator; opening this file with other programs or sending it to a braille embosser will yield unexpected results and is not recommended. The Save File command can be issued using the Control-S keyboard shortcut.

Different web browsers implement the Save File command in different ways (see Saving and Exporting).

Export File

Choosing Export File will export the current score to a file on your computer's hard disk. You will be given the option of naming the file before exporting. The score is translated into Braille ASCII (see Braille ASCII) and the file type produced (.brf) is designed to work with braille embossers and other braille technology. This type of file can be opened again in Braille Music Notator, but will require the program to reparse the braille symbols and may yield unexpected results; it is recommended that you save your score using Save File for future editing in Braille Music Notator, and use Export File only for sending the score to embossers or other programs. The Export File command can be issued using the Control-E keyboard shortcut.

If "Show Page Breaks" is selected (see Options), exported files will not include any characters located beyond the right margin of the score.

Different web browsers implement the Export File command in different ways (see Saving and Exporting).

Parse Imported Files

In braille music notation, certain braille characters can have multiple meanings depending the context in which they are used. By default, when Braille Music Notator opens a file created in another utility, it attempts to interpret braille characters contextually in order to display the correct icon in the score. This same translation is done when information copied from other programs and pasted into the notation area using the Paste command (Control-V). This functionality can be disabled by deselecting the Parse Imported Files checkbox in the File Tab. The Parse Imported Files setting can be enabled and disabled using the Control-H keyboard shortcut.

In some cases, Braille Music Notator is unable to ascertain the meaning of certain braille characters through their context. If, after opening a braille notation file, you see unexpected symbols, select them and use the Control-R keyboard shortcut to cycle through other possible meanings of the character (see Braille Music Characters).

Saving and Exporting

Due to the variance in security techniques among different browsers, Save File and Export File might work differently, and may require an extra step:

In addition, saved and exported files may be given generic filenames and extensions by your web browser. It may be beneficial to rename the files after they are saved to disk. Exported files should be given a file extension of ".brf" or ".txt" to work with certain braille software or hardware.

Autosave

Braille Music Notator automatically stores the current score in your web browser's "cookie" file, a small, secured storage space on your computer accessible only to the web page which created it. This file is read automatically when Braille Music Notator is opened.

While users are urged to save their work often (see Saving and Exporting), the autosave feature will automatically restore your current score if Braille Music Notator is closed inadvertantly, either by closing the browser window, navigating to a different page, or experiencing an error which causes your web browser to quit.

Because the autosave feature is automatic, when opening Braille Music Notator, the notation area may display the score you were previously working on. If you wish to work on a different score, either open a different file (see Open File) or create a new, empty score (see New File).

In addition to saving the score in its current form, Braille Music Notator stores a limited number of previous states of your score, allowing you to use Undo command (see Undo and Redo) after reopening Braille Music Notator with a restored score.

Options

To view the Options tab, click the Options button in the upper right-hand corner of the Braille Music Notator window. To close the Options tab, click the Options button again.

Show Translated Braille

By default, Braille Music Notator replaces braille characters with the musical symbols they represent. This automatic translation can be disabled and enabled by selecting Show Translated Braille in the Options tab. This setting can also be toggled with the Control-B keyboard shortcut.

Show Small Dots

When braille characters are displayed, empty dot positions are indicated by a small dot in the braille character. This setting can be disabled and enabled by selecting Show Small Dots in the Options tab. This setting can also be toggled with the Control-D keyboard shortcut.

Score Size

Magnification of the notation area can be changed using the Score Size setting in the Options tab. The value shown is the height of a single cell in pixels; the default value is 60. Clicking the arrows will increase or decrease this value by 10. The lowest available value is 10; there is no upper limit. Magnification can also be reduced by 10 with the Control-Hyphen keyboard shortcut, and increased by 10 with the Control-Equals keyboard shortcut. This setting has no effect on embossed scores; it simply controls the view of the score in the notation area.

Show Page Breaks

By default, the notation area displays a horizontal gray line to show where page breaks will occur, and a gray area on the right to illustrate page width. These visual cues can be disabled and enabled using the Show Page Breaks setting in the Options tab. Page height and width can be changed using the Page Size settings in the Options tab (see Page Size).

When Show Page Breaks is enabled, exported files will include a page break character after each page, and will not include any characters to the right of the page width boundary (see Export File). Saved files are not affected by the Show Page Breaks setting.

Page Size

The size of the page as shown by the page boundary markers (see Show Page Breaks) can be changed using the Page Size settings, labeled "Width" and "Height," in the Options tab. Width and height are shown in cells. Clicking the arrows next to the appropriate value will change that value by one. Additionally, page height can be increased using the Control-K keyboard shortcut and decreased using the Control-I keyboard shortcut, and page width can be increased with the Control-L keyboard shortcut and decreased with the Control-J keyboard shortcut.

Use Word Wrap

When Use Word Wrap and selected and Show Page Breaks is enabled, once the cursor reaches the end of the line, the cursor and current group of symbols will be automatically moved to the next line. (In literary braille, this grouping corresponds to the current word; in music braille, this grouping corresponds to the current measure.) Octave symbols will be placed automatically in accordance with braille music conventions.

Controls

The controls area in Braille Music Notator can be set to different arrangements. The default arrangement, "Classic," includes a general variety of braille music symbols used in most scores. Other available arrangements are available in the Controls menu. To select a different arrangement, choose the arrangement from the Controls menu; the controls area will update immediately. The score and notation area are not affected.

At this time, two arrangements are available: "Classic," the default controls arrangement, and "MIDI," an arrangement designed for use with MIDI keyboard entry (See MIDI Note Entry).

Insert Octave Symbols

When a MIDI-capable controls arrangement is selected (see MIDI Note Entry), the Insert Octave Symbols option controls whether or not Braille Music Notator will automatically add octave symbols to entered notes according to braille music conventions. If Insert Octave Symbols is not selected, octave symbols must be entered manually.

Observe Key Signatures

When a MIDI-capable controls arrangement is selected (see MIDI Note Entry), the Observe Key Signatures option controls whether or not Braille Music Notator will automatically show or hide accidentals based on the most recent indicated key signature. If Observe Key Signatures is not selected, sharps and flats will always be included for chromatic notes entered via MIDI.

MIDI Note Entry

For a visual demonstration of MIDI Note Entry in Braille Music Notator, visit the Video Tutorials page.

Notes can be entered into Braille Music Notator using a MIDI keyboard (or any other MIDI-capable instrument) connected to the computer. To use a MIDI keyboard with Braille Music Notator, connect the keyboard to your computer; consult your MIDI keyboard user manual for detailed instructions. Ensure that the MIDI keyboard is recognized by your computer's operating system using Audio/MIDI Setup on MacOS or MIDI Mapper on Windows. Lastly, ensure that a MIDI-capable controls arrangement is selected from the Controls menu in the Options tab (see Controls).

MIDI-Compatible Browsers

To use MIDI note entry, Braille Music Notator must be open in a browser which can access the Web MIDI API. Currently, Chrome, Edge and Opera support MIDI. Firefox can be made to support MIDI by installing the Web MIDI API extension. Safari does not support MIDI, and there are currently no extensions which allow it to do so.

Entering Notes with MIDI

To enter notes using MIDI, press and hold one or more notes on the MIDI keyboard. Before releasing the note or notes, click the appropriate note length in the control area or press the corresponding key on the computer keyboard. The symbol matching note length and pitch will be entered into the score, along with any necessary octave symbol (see Insert Octave Symbols) and accidentals (see Observe Key Signatures). Repeated notes of the same pitch can be added by pressing the note length key while continuing to hold down the note or notes on the MIDI keyboard.

Entering Rests with MIDI

To enter a rest using a MIDI-capable controls arrangement, press the corresponding note duration key without holding down a note on the MIDI keyboard.

Screen Reader Compatibility

While Braille Music Notator was designed with the intention of making braille music more accessible for sighted users, all aspects of the utility are available using screen reading software. Braille Music Notator adheres to WAI-ARIA standards for web applications, and has been tested with VoiceOver on MacOS and JAWS on Windows. Other screen readers which adhere to WAI-ARIA standards should be compatible. Windows' built-in screen reader, Narrator, is not supported at this time.

When screen reading software is enabled and the browser window containing Braille Music Notator is active, the screen reading software will respond to each keypress or mouse click with three items in the following order:

  1. If the keypress made a change to the score or exceuted a command, a description of what happened will be announced (for example, "Cleared cell at line 4, character 3," or "Magnification Increased by 10."). If a new character was added, the name of the character will be announced.
  2. The current location of the cursor in the format "Line X, Character Y." Note that the first row and column are numbered as 0, so the cell in the top left corner of the score is line 0, character 0.
  3. The name of the character in the cursor's current position. If the currently selected cell is blank, the screen reader announces the word "empty."

Using a Refreshable Braille Display

Instead of providing descriptive text, Braille Music Notator can be set to output the full line of braille at the cursor's current position, which provides functionality with refreshable braille displays. To toggle output between using descriptive text and braille characters, use the keyboard shortcut Control-U.

Using Braille Music Notator Offline

Braille Music Notator is a web application, and is designed to be used with an active internet connection. It can, however, be downloaded to your computer's hard drive and used without an internet connection. To use Braille Music Notator offline:

  1. Install and launch web server software on your computer. The directions for this vary depending upon the operating system. This site gives one method for accomplishing this.
  2. Download the current archived version of Braille Music Notator. If necessary, decompress the archive file using a "unzip" utility.
  3. Place the decompressed archive in your web server's documents folder, and point your browser to http://127.0.0.1/notator/.

Unfortunately, MIDI Note Entry, which requires a secured browser connection, will not work when using Braille Music Notator on a local server.

Note also that the online version of Braille Music Notator receives periodic updates, which add features and fix errors. These updates will not be reflected in archived versions. To update an archived version, delete the Braille Music Notator archive on your computer and repeat the steps above.

Using the Keyboard

All features in Braille Music Notator are accessible using the computer keyboard, allowing for quicker editing and accessibility to those unable to use the graphic interface.

Keyboard Score Entry

Pressing a key on the keyboard without any modifier keys (such as shift, control, etc.) adds a musical symbol to the score according to the current keyboard setting within Braille Music Notator. Both controls arrangements have multiple keyboard layouts. Pressing the tab key will move to the next keyboard layout, and pressing shift-tab will move to the previous keyboard layout. Keyboard layouts will "wrap around" from the last to the first and vice versa.

Pressing the shift key while adding a character will insert the character at the current position, moving any remaining characters on that line one cell to the right.

For a textual representation of the keyboards, see the Keyboard Entry Chart.

Keyboard Editing Commands

The following keys can be used to move the cursor or change the selection in the notation area:

Keyboard Shortcuts

Commands in Braille Music Notator can be executed with keyboard shortcuts. Using a shortcut requires pressing a particular key while holding a modifier key. Due to the differences between web browsers, which modifier key to use will vary. In most cases, the Control key will work for most shortcuts. In some cases, Control key shortcuts are used by the web browser for other functions; in these cases, the Command key on Mac OS or the Windows key in Windows will work instead.

Keyboard Shortcuts are listed in the following table:

8 Toggle Insert Octave Symbols (MIDI Entry only)
9 Toggle Observe Key Signatures (MIDI Entry only)
0 Toggle Spell Chords Downward (MIDI Entry only)
A Select All
B Toggle Braille Translation
C Copy
D Toggle Small Dots
E Export File
H Toggle Parse Imported Files
I Decrease Page Height by 1
J Decrease Page Width by 1
K Increase Page Height by 1
L Increase Page Width by 1
N New Document
O Open Document
P Toggle Page Breaks
R Cycle Through Symbol Meanings
S Save File
T Convert Selected Characters to Text
(with Shift key: Convert Selected Characters to Music)
U Toggle between screen reader and refreshable braille display modes
V Paste
X Cut
Y Redo
Z Undo
= Increase Magnification by 10
- Decrease Magnification by 10
, Toggle Use Word Wrap
? Help
` Rotate Through Control Arrangements
Up Arrow Delete Row
Down Arrow Insert Row

Working with Braille

One of the primary goals of Braille Music Notator is to allow sighted users to create braille music scores without requiring fluency in braille. However, a basic understanding of braille and how it is used in computer files is very helpful.

About Braille

Braille is a system of recording information using raised dots, developed in 1824 by French educator Louis Braille. While braille is traditionally rendered by embossing heavier-weight paper, the system can be used with any materials. Braille characters (sometimes called cells) are created by arranging dots in a small 2x3 grid. Variants of the system have been developed for many different languages. English braille consists of two standardized subsystems: Grade 1, which uses a simple correlation of braille characters to letters, numbers and punctuation; and Grade 2, which features a large number of contractions and abbreviations to conserve space.

While braille shares many one-to-one correlations with the Latin alphabet, there are some important differences between the systems, even when using Grade 1 braille. For example, while the Latin alphabet uses different symbols for upper- and lowercase letters, braille instead uses a prefix character to indicate that the next character should be capitalized. Additional differences occur with punctuation.

Braille documents are generally created using a braille embosser; early embossers worked as typewriters, while modern embossers connect to computers. Braille can also be dynamically generated using a refreshable braille display, which can be connected to a computer as an output device. Braille readers often use notetakers, devices analagous to laptop computers but which feature a refreshable braille display instead of a screen, and which sometimes use a braille keypad in lieu of a traditional keyboard.

Braille ASCII

The standard method for storing English braille documents digitally is braille ASCII. Like traditional ASCII, braille ASCII encodes each character with a numeric code from 1 to 127. Many of these characters — specifically, the letters A–Z — mirror their traditional ASCII counterparts. Because of this, when braille ASCII is translated as regular ASCII, the meaning of the text can often be inferred, even when Grade 2 contractions are used.

Because modern embossers connect to computers using a text-based printer interface — much like an older dot-matrix printer — they operate by receiving a text file from the computer. This encoding for this text file should be braille ASCII. Sending a traditional ASCII file will generate braille characters, but due to the differences between braille ASCII and traditional ASCII the result will not be legible braille.

The standard format for saving braille documents on a computer is identical to a standard text file, but uses the extension ".brf" to indicate that the contents are encoded using braille ASCII.

Braille Music Characters

Braille music notation was first developed by Louis Braille himself, who was a talented organist. The system uses the same characters as literary braille, but assigns different meanings to them for use in a musical context. Because of the number of different musical symbols, a single braille character might be given a number of different meanings depending on context. Some musical symbols are encoded using sequences of two or three braille characters.

Braille Music Notator uses a system of storing symbols that preserves the musical meaning of a given braille character, but which allows the user to cycle through these meanings if necessary. To change to a different musical symbol for a particular braille character, place the cursor on the character in the notation area and use the Control-R keyboard shortcut. Repeat to cycle through all the meanings of the braille character.

Saving the file (see Save File) preserves all musical meanings for the braille characters in the score. Exporting the file (see Export File) creates a braille ASCII file which is suitable for sending to a braille embosser but which does not preserve musical meanings.

If a standard braille ASCII file (such as one exported from Braille Music Notator, or created by another braille music utility) is imported into Braille Music Notator, the utility will attempt to determine the appropriate meanings of each character based on its context (see Parse Imported Files). These meanings will be preserved in saved files. In cases where Braille Music Notator is unable to correctly determine the proper meaning, the Control-R keyboard shortcut can be used to cycle through possible interpretations for each character.

Literary Braille

To enter literary braille characters in Braille Music Notator, select the literary braille keyboard by clicking the "Aa" button in the control area. When this keyboard is selected, any characters pasted into the notation area from the clipboard (using the Control-V keyboard shortcut) is interpreted as literary braille.

Braille Music Notator is not intended for extensive textual input; to add large blocks of text, it is easier to copy text from a program or utility designed for this purpose, select the literary braille keyboard in the control area, and paste it into the notation area.

Unicode Braille Characters

Braille characters are represented in the Unicode specification as character codes U+2800 to U+28FF. These are intended for displaying images of the braille characters as graphics on screen or in print, and are generally not used in the embossing process. They are sometimes used in materials about braille written for sighted users. When these characters are copied to the clipboard (from a PDF file about braille music, for example) and pasted into Braille Music Notator, they are automatically translated into braille ASCII and parsed contextually (see Parse Imported Files).

Braille Music Viewer

The functionality of Braille Music Notator is available in a read-only format for inclusion on web pages who wish to include interactive excerpts of scores in braille music format. Visit the Braille Music Viewer page for information on how to include braille music in your own web pages.

Development

Braille Music Notator is open source software. If you would like to contribute to the development of Braille Music Notator, visit the code respository. Recent development versions of the software are available there for download.

About the Developer

Braille Music Notator is designed and maintained by Dr. Toby W. Rush, associate professor of music theory and technology at the University of Dayton in Dayton, Ohio. For more information about Dr. Rush, including his popular theory reference Music Theory for Musicians and Normal People, visit tobyrush.com.

Dr. Rush would like to thank Ryan Betts and Kaiti Shelton for their invaluable assistance with this project.

Any and all feedback about this project is welcome: contact Dr. Rush by email here.

Reference

Keyboard Entry Charts

Alternate versions of the keyboard diagrams in the control area of Braille Music Notator are available from the Keyboard Entry page.